meil status

All systems are operational. — All meil services are monitored in real time.

Video meetings (Meil Meet) – service disruption

This page provides real-time information about an incident affecting WAYSCloud systems.

Video meetings and Video meetings

Fixed

1 month ago —

The problem with Meil Meet (video meetings) has been fixed, and the service is now operating normally in all countries. Thank you for your patience.

Identified

1 month ago —

We have identified the cause of the problem with Meil Meet (video meetings) and are now working on a fix. We will update as soon as the service is back.

1 month ago —

We are currently experiencing problems with Meil Meet (video meetings). The issue affects all countries. We are investigating and will provide an update as soon as we know more.

Incident UUID 5ca5bcc1-bbd5-4572-88d2-265a0a7c7535 Closed incidents and investigations may be documented in the WAYSCloud Trust Center.