meil status

All systems are operational. — All meil services are monitored in real time.

Problems displaying email in the browser

This page provides real-time information about an incident affecting WAYSCloud systems.

Email, Email and Email

Fixed

1 month ago —

Post-incident report with root cause analysis is now published in our Trust Center: Read the report.

Fixed

1 month ago —

The issue has been resolved. We take this incident seriously and will investigate the root cause afterwards.

Identified

1 month ago —

The root cause has been identified and we are working on a fix.

1 month ago —

We are experiencing problems displaying email in the browser (webmail). We are investigating the incident. IMAP and SMTP are working normally, so email can still be sent and received via standard email clients.

Incident UUID 8c63a3e8-4ee0-4ed2-9ea7-efc5642363dd Closed incidents and investigations may be documented in the WAYSCloud Trust Center.